NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2025-32968 — xwiki-platform-oldcore

CVE-2025-32968 is a SQL Injection vulnerability in org.xwiki.platform:xwiki-platform-oldcore. A fix is available for org.xwiki.platform:xwiki-platform-oldcore — see the affected versions and patch details below.

org.xwiki.platform:xwiki-platform-oldcore allows SQL injection in short form select requests through the script query API

Also known asGHSA-g9jj-75mx-wjcx
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32968.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.58%1.15%1.73%1.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
☕org.xwiki.platform:xwiki-platform-oldcore☕org.xwiki.platform:xwiki-platform-oldcore☕org.xwiki.platform:xwiki-platform-oldcore

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

It is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend.

Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries.

The vulnerability may be tested in a default installation of XWIki Standard Flavor, including using the official Docker containers.

For example, with a MySQL or MariaDB database, you can use the following script (which a user having SCRIPT right but not PROGRAMMING right) to get the content of the xwikistrings table (which contain all the short string fields stored in objects, including passwords):

{{velocity}}
$services.query.hql("where 1<>'1\'' union select concat(XWS_NAME, XWS_VALUE) from xwikistrings #'").execute()
{{/velocity}}

Patches

This has been patched in 16.10.1, 16.4.6 and 15.10.16.

Workarounds

There is no known workaround, other than upgrading XWiki.

The protection added to this REST API is the same as the one used to validate complete select queries, making it more consistent. However, while the script API always had this protection for complete queries, it's important to note that it's a very strict protection and some valid, but complex, queries might suddenly require the author to have programming right.

References

https://jira.xwiki.org/browse/XWIKI-22718

For more information

If you have any questions or comments about this advisory:

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.xwiki.platform:xwiki-platform-oldcore≥ 1.6-milestone-1&&< 15.10.1615.10.16org.xwiki.platform:xwiki-platform-oldcore:15.10.16
☕Mavenorg.xwiki.platform:xwiki-platform-oldcore≥ 16.0.0-rc-1&&< 16.4.616.4.6org.xwiki.platform:xwiki-platform-oldcore:16.4.6
☕Mavenorg.xwiki.platform:xwiki-platform-oldcore≥ 16.5.0-rc-1&&< 16.10.116.10.1org.xwiki.platform:xwiki-platform-oldcore:16.10.1

Affected Products

1 product · 3 configurations
Application
xwikixwiki
≥ 16.5.0 && ≤ 16.10.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-oldcore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.xwiki.platform:xwiki-platform-oldcore to 15.10.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32968 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

### Impact It is possible for a user with SCRIPT right to escape from the HQL execution context and perform a blind SQL injection to execute arbitrary SQL statements on the database backend. Depending on the used database backend, the attacker may be able to not only obtain confidential information such as password hashes from the database, but also execute UPDATE/INSERT/DELETE queries. The vulnerability may be tested in a default installation of XWIki Standard Flavor, including using the official Docker containers. For example, with a MySQL or MariaDB database, you can use the following s
O3 Security · Impact-Aware SCA

Is CVE-2025-32968 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-32968: xwiki-platform — Fixed in 15.10.16