CVE-2025-32020 — crud-query-parser
CVE-2025-32020 is a SQL Injection vulnerability in crud-query-parser. A fix is available for crud-query-parser — see the affected versions and patch details below.
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') in crud-query-parser
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-32020.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
crud-query-parsernpmDescription
Impact
Improper neutralization of the order/sort parameter in the TypeORM adapter, which allows SQL injection.
You are impacted by this vulnerability if you are using the TypeORM adapter, ordering is enabled and you have not set-up a property filter.
Versions 0.0.1, 0.0.2 and 0.0.3 are affected by this vulnerability.
Patches
This vulnerability has been fixed in version 0.1.0 and newer, which introduces TypeORM field validation (enabled by default).
Workarounds
Add an allowlist of fields
List all valid fields and use the filterProperties function to filter out invalid fields before passing the crudRequest to the TypeOrmQueryAdapter. Here's an example:
crudRequest = filterProperties(crudRequest, ['id', 'title', 'category.name']);
Disable ordering
Cleanup the order field just before passing it to the TypeOrmQueryAdapter. Here's an example:
crudRequest.order = [];
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | crud-query-parser | all versions | 0.1.0npm install crud-query-parser@0.1.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for crud-query-parser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update crud-query-parser to 0.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-32020 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2025-32020 in your dependencies?
Find it across npm, including transitive dependencies.