CVE-2025-31651 is a critical-severity (CVSS 9.8) CWE-116 vulnerability in org.apache.tomcat:tomcat-catalina. A fix is available for org.apache.tomcat:tomcat-catalina — see the affected versions and patch details below.
Apache Tomcat: Bypass of rules in Rewrite Valve
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-31651.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat.embed:tomcat-embed-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. For a subset of unlikely rewrite rule configurations, it was possible for a specially crafted request to bypass some rewrite rules. If those rewrite rules effectively enforced security constraints, those constraints could be bypassed.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.5, from 10.1.0-M1 through 10.1.39, from 9.0.0.M1 through 9.0.102. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6, which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 9.0.76&&< 9.0.104 | 9.0.104org.apache.tomcat:tomcat-catalina:9.0.104 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 10.1.10&&< 10.1.40 | 10.1.40org.apache.tomcat:tomcat-catalina:10.1.40 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 11.0.0-M2&&< 11.0.6 | 11.0.6org.apache.tomcat:tomcat-catalina:11.0.6 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.76&&< 9.0.104 | 9.0.104org.apache.tomcat.embed:tomcat-embed-core:9.0.104 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.10&&< 10.1.40 | 10.1.40org.apache.tomcat.embed:tomcat-embed-core:10.1.40 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.0-M2&&< 11.0.6 | 11.0.6org.apache.tomcat.embed:tomcat-embed-core:11.0.6 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-catalina, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-catalina to 9.0.104 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31651 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as Low severity because it only manifests under a narrow set of conditions involving uncommon and non-default rewrite rule configurations that rely on specific patterns in the raw requestURI, including path parameters. In most deployments, rewrite rules operate on decoded and normalized…
No mitigation is currently available that meets Red Hat Product Security’s standards for usability, deployment, applicability, or stability.Source: Red Hat security advisory for CVE-2025-31651 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.36-3.el10_1.1 | RHSA-2025:23050 |
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.87-8.el10_1.1 | RHSA-2025:23052 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat-1:10.1.36-1.el10_0.3 | RHSA-2025:23051 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat9-1:9.0.87-5.el10_0.4 | RHSA-2025:23053 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.87-1.el8_10.7 | RHSA-2025:23048 |
| Red Hat Enterprise Linux 8.2 Advanced Update Support | pki-deps:10.6-8020020260128173505.4cda2c84 | RHSA-2026:2725 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | pki-deps:10.6-8040020260129154709.522a0ee4 | RHSA-2026:2724 |
| Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support | pki-deps:10.6-8060020260128101437.ad008a3a | RHSA-2026:2726 |
Frequently Asked Questions
Is CVE-2025-31651 in your dependencies?
Find it across Maven, including transitive dependencies.