CVE-2025-31485 is a high-severity (CVSS 7.5) CWE-696 vulnerability in api-platform/graphql. A fix is available for api-platform/graphql — see the affected versions and patch details below.
GraphQL grant on a property might be cached with different objects
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-31485.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
api-platform/graphql🐘api-platform/core🐘api-platform/graphql🐘api-platform/core🐘api-platform/core🐘api-platform/graphqlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Original message:
I found an issue with security grants on on properties in the GraphQL ItemNormalizer:
If you use something like #[ApiProperty(security: 'is_granted("PROPERTY_READ", [object, property])')] on a member of an entity, the grant gets cached and is only evaluated once, even if the object in question is a different one.
There is the ApiPlatform\GraphQl\Serializer\ItemNormalizer::isCacheKeySafe() method that seems to be intended to prevent this: https://github.com/api-platform/core/blob/88f5ac50d20d6510686a7552310cc567fcca45bf/src/GraphQl/Serializer/ItemNormalizer.php#L160-L164
and in its usage on line 90 it does indeed not create a cache key, but the parent::normalize() that is called afterwards still creates the cache key and causes the issue.
Impact
It grants access to properties that it should not.
Workarounds
Override the ItemNormalizer.
Patched at: https://github.com/api-platform/core/commit/7af65aad13037d7649348ee3dcd88e084ef771f8
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | api-platform/graphql | ≥ 4.0.0-alpha.1&&< 4.0.22 | 4.0.22composer require api-platform/graphql:^4.0.22 |
| 🐘Packagist | api-platform/core | ≥ 4.0.0-alpha.1&&< 4.0.22 | 4.0.22composer require api-platform/core:^4.0.22 |
| 🐘Packagist | api-platform/graphql | all versions | 3.4.17composer require api-platform/graphql:^3.4.17 |
| 🐘Packagist | api-platform/core | all versions | 3.4.17composer require api-platform/core:^3.4.17 |
| 🐘Packagist | api-platform/core | ≥ 4.1.0-alpha.1&&< 4.1.5 | 4.1.5composer require api-platform/core:^4.1.5 |
| 🐘Packagist | api-platform/graphql | ≥ 4.1.0-alpha.1&&< 4.1.5 | 4.1.5composer require api-platform/graphql:^4.1.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for api-platform/graphql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update api-platform/graphql to 4.0.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31485 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-31485 in your dependencies?
Find it across Packagist, including transitive dependencies.