NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
LOW severity

CVE-2025-31363 — server

LOW

CVE-2025-31363 is a low-severity (CVSS 3) vulnerability in github.com/mattermost/mattermost/server/v8. A fix is available for github.com/mattermost/mattermost/server/v8 — see the affected versions and patch details below.

Data exfiltration via AI plugin Jira tool

Also known asGHSA-9h6j-4ffx-cm84GO-2025-3622
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs21th percentile — riskier than 21% of all scored CVEsHighest risk
0.00%0.26%0.53%0.79%0.2%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.5.0&&< 10.5.110.5.1go get github.com/mattermost/mattermost/server/v8@v10.5.1
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.4.0&&< 10.4.310.4.3go get github.com/mattermost/mattermost/server/v8@v10.4.3
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.11.0&&< 9.11.109.11.10go get github.com/mattermost/mattermost/server/v8@v9.11.10
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20250218121836-2b5275d87136go get github.com/mattermost/mattermost/server/v8@v8.0.0-20250218121836-2b5275d87136

Affected Products

1 product · 3 configurations
Application
mattermost servermattermost
≥ 10.4.0 && < 10.4.3
1 version
10.5.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost/server/v8, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost/server/v8 to 10.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31363 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.
O3 Security · Impact-Aware SCA

Is CVE-2025-31363 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-31363: server — Fixed in 10.5.1