CVE-2025-31129 is a high-severity (CVSS 8.8) Deserialization of Untrusted Data vulnerability in io.jooby:jooby-pac4j. A fix is available for io.jooby:jooby-pac4j — see the affected versions and patch details below.
jooby-pac4j: deserialization of untrusted data
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-31129.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.jooby:jooby-pac4j☕io.jooby:jooby-pac4jReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Versions after 2.x and before 3.x of io.jooby:jooby-pac4j can cause deserialization of untrusted data
Patches
- 2.17.0 (2.x)
- 3.7.0 (3.x)
Workarounds
- Not using io.jooby:jooby-pac4j until it gets patches.
- Check what values you put/save on session
References
Version 2.x:
Cause
In module pac4j io.jooby.internal.pac4j.SessionStoreImpl#get , it is used to handle sessions , and trying to get key value. In strToObject function ,it's trying to deserialize value when value starts with "b64~" , which might cause deserialization of untrusted data.
modules/jooby-pac4j/src/main/java/io/jooby/internal/pac4j/SessionStoreImpl.java
Here's a small demo using SessionStoreImpl#get to handle sessions ,and user can pass parameters.
And following below is exploiting successfully(execute calculator)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.jooby:jooby-pac4j | all versions | 2.17.0io.jooby:jooby-pac4j:2.17.0 |
| ☕Maven | io.jooby:jooby-pac4j | ≥ 3.0.0.M1&&< 3.7.0 | 3.7.0io.jooby:jooby-pac4j:3.7.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.jooby:jooby-pac4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.jooby:jooby-pac4j to 2.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-31129 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2025-31129 in your dependencies?
Find it across Maven, including transitive dependencies.