NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven🐍 PyPI📦 SwiftURL
Not in CISA KEV
HIGH severity

CVE-2025-30402 — executorch-android

HIGHFix: pytorch/executorch@93b1a0c

CVE-2025-30402 is a high-severity (CVSS 8.1) remote code execution vulnerability in org.pytorch:executorch-android. A fix is available for org.pytorch:executorch-android — see the affected versions and patch details below.

ExecuTorch vulnerable to Heap-based Buffer Overflow attack

Also known asGHSA-h952-963h-rv99PYSEC-2026-1352
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-30402.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk
0.00%0.31%0.62%0.93%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.pytorch:executorch-android🐍executorch📦github.com/pytorch/executorch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven, PyPI, SwiftURL packages — download data is not available via public APIs for these ecosystems.

Description

A heap-buffer-overflow vulnerability in the loading of ExecuTorch methods can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit 93b1a0c15f7eda49b2bc46b5b4c49557b4e9810f

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.pytorch:executorch-androidall versions0.7.0-rc1org.pytorch:executorch-android:0.7.0-rc1
🐍PyPIexecutorchall versions0.7.0pip install --upgrade 'executorch==0.7.0'
📦SwiftURLgithub.com/pytorch/executorchall versions0.7.0-rc1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.pytorch:executorch-android, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.pytorch:executorch-android to 0.7.0-rc1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-30402 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

A heap-buffer-overflow vulnerability in the loading of ExecuTorch methods can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit 93b1a0c15f7eda49b2bc46b5b4c49557b4e9810f
O3 Security · Impact-Aware SCA

Is CVE-2025-30402 in your dependencies?

Find it across Maven, PyPI, SwiftURL, including transitive dependencies.

CVE-2025-30402: executorch-android — Fixed in 0.7.0-rc1