CVE-2025-30214 — frappe
CVE-2025-30214 is a Information Exposure vulnerability in frappe. A fix is available for frappe — see the affected versions and patch details below.
Frappe vulnerable to information disclosure leading to account takeover
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
frappe🐍frappeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Frappe is a full-stack web application framework. Prior to versions 14.89.0 and 15.51.0, making crafted requests could lead to information disclosure that could further lead to account takeover. Versions 14.89.0 and 15.51.0 fix the issue. There's no workaround to fix this without upgrading.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | frappe | all versions | 14.89.0pip install --upgrade 'frappe==14.89.0' |
| 🐍PyPI | frappe | ≥ 15.0.0&&< 15.51.0 | 15.51.0pip install --upgrade 'frappe==15.51.0' |
Affected Products
frappefrappeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for frappe, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update frappe to 14.89.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-30214 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-30214 in your dependencies?
Find it across PyPI, including transitive dependencies.