NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2025-29926 — xwiki-platform-wiki-rest-…

Fix: xwiki/xwiki-platform@82aa670

CVE-2025-29926 is a CWE-285 vulnerability in org.xwiki.platform:xwiki-platform-wiki-rest-default. A fix is available for org.xwiki.platform:xwiki-platform-wiki-rest-default — see the affected versions and patch details below.

The WikiManager REST API allows any user to create wikis

Also known asGHSA-gfp2-6qhm-7x43
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-29926.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.03%0.82%1.61%2.39%1.9%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
☕org.xwiki.platform:xwiki-platform-wiki-rest-default☕org.xwiki.platform:xwiki-platform-wiki-rest-default☕org.xwiki.platform:xwiki-platform-wiki-rest-default

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager.

Patches

The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module.

Workarounds

There's no workaround other than upgrading the dependency.

References

For more information

If you have any questions or comments about this advisory:

Attribution

You can specify here who reported the issue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.xwiki.platform:xwiki-platform-wiki-rest-default≥ 5.4-rc-1&&< 15.10.1515.10.15org.xwiki.platform:xwiki-platform-wiki-rest-default:15.10.15
☕Mavenorg.xwiki.platform:xwiki-platform-wiki-rest-default≥ 16.0.0-rc-1&&< 16.4.616.4.6org.xwiki.platform:xwiki-platform-wiki-rest-default:16.4.6
☕Mavenorg.xwiki.platform:xwiki-platform-wiki-rest-default≥ 16.5.0-rc-1&&< 16.10.016.10.0org.xwiki.platform:xwiki-platform-wiki-rest-default:16.10.0

Affected Products

1 product · 5 configurations
Application
xwikixwiki
≥ 16.5.0 && < 16.10.0
1 version
5.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-wiki-rest-default, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.xwiki.platform:xwiki-platform-wiki-rest-default to 15.10.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-29926 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact Any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager. ### Patches The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module. ### Workarounds There's no workaround other than upgrading the dependency. ### References * JIRA ticket: https://jira.xwiki.org/browse/XWIKI-22490 * Commit of the fix: https://github.com/x
O3 Security · Impact-Aware SCA

Is CVE-2025-29926 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-29926: Fixed in 15.10.15