CVE-2025-2901 is a medium-severity (CVSS 4.6) vulnerability in org.jboss.hal:hal-console. A fix is available for org.jboss.hal:hal-console — see the affected versions and patch details below.
HAL Cross Site Scripting (XSS) vulnerability of user input when storing it in a data store
Real-World Exposure
org.jboss.hal:hal-consoleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in the JBoss EAP Management Console, where a stored Cross-site scripting vulnerability occurs when an application improperly sanitizes user input before storing it in a data store. When this stored data is later included in web pages without adequate sanitization, malicious scripts can execute in the context of users who view these pages, leading to potential data theft, session hijacking, or other malicious activities.
Impact
Cross-site scripting (XSS) vulnerability in the management console.
Patches
Fixed in HAL 3.7.11.Final
Workarounds
No workaround available
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jboss.hal:hal-console | all versions | 3.7.11.Finalorg.jboss.hal:hal-console:3.7.11.Final |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jboss.hal:hal-console, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jboss.hal:hal-console to 3.7.11.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-2901 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This CVE has been marked as Rejected by the assigning CNA.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Application Platform 7 | org.jboss.hal-hal-parent | RHSA-2025:10931 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-activemq-artemis-0:2.16.0-21.redhat_00055.1.el8eap | RHSA-2025:10925 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9 | eap7-activemq-artemis-0:2.16.0-21.redhat_00055.1.el9eap | RHSA-2025:10926 |
| Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7 | eap7-activemq-artemis-0:2.16.0-21.redhat_00055.1.el7eap | RHSA-2025:10924 |
| Red Hat JBoss Enterprise Application Platform 8.0.8 | org.jboss.hal-hal-parent | RHSA-2025:10459 |
| Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 8 | eap8-activemq-artemis-0:2.33.0-3.redhat_00017.1.el8eap | RHSA-2025:10452 |
| Red Hat JBoss Enterprise Application Platform 8.0 for RHEL 9 | eap8-activemq-artemis-0:2.33.0-3.redhat_00017.1.el9eap | RHSA-2025:10453 |
Frequently Asked Questions
Is CVE-2025-2901 in your dependencies?
Find it across Maven, including transitive dependencies.