CVE-2025-27821 is a high-severity (CVSS 7.3) Out-of-bounds Write vulnerability in org.apache.hadoop:hadoop-hdfs-native-client. A fix is available for org.apache.hadoop:hadoop-hdfs-native-client — see the affected versions and patch details below.
HDFS native client: Out of bounds write in URI parser of native HDFS client
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-27821.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.hadoop:hadoop-hdfs-native-clientReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.
This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.
Users are recommended to upgrade to version 3.4.2, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.hadoop:hadoop-hdfs-native-client | ≥ 3.2.0&&< 3.4.2 | 3.4.2org.apache.hadoop:hadoop-hdfs-native-client:3.4.2 |
Affected Products
hadoopapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.hadoop:hadoop-hdfs-native-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.hadoop:hadoop-hdfs-native-client to 3.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-27821 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2025-27821 in your dependencies?
Find it across Maven, including transitive dependencies.