NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-27604 — application-confluence-mi…

HIGHFix: xwikisas/application-confluence-migrator-pro@6ced42b

CVE-2025-27604 is a high-severity (CVSS 7.5) Information Exposure vulnerability in com.xwiki.confluencepro:application-confluence-migrator-pro-ui. A fix is available for com.xwiki.confluencepro:application-confluence-migrator-pro-ui — see the affected versions and patch details below.

XWiki Confluence Migrator Pro's homepage is public

Also known asGHSA-3w9f-2pph-j5vc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-27604.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs32th percentile — riskier than 32% of all scored CVEsHighest risk
0.00%0.36%0.73%1.09%0.2%0.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.xwiki.confluencepro:application-confluence-migrator-pro-ui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

XWiki Confluence Migrator Pro helps admins to import confluence packages into their XWiki instance. The homepage of the application is public which enables a guest to download the package which might contain sensitive information. This vulnerability is fixed in 1.11.7.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.xwiki.confluencepro:application-confluence-migrator-pro-uiall versions1.11.7com.xwiki.confluencepro:application-confluence-migrator-pro-ui:1.11.7

Affected Products

1 product · 1 configurations
Application
confluence migratorxwiki
< 1.11.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.xwiki.confluencepro:application-confluence-migrator-pro-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.xwiki.confluencepro:application-confluence-migrator-pro-ui to 1.11.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-27604 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

### Impact The homepage of the application is public which enables a guest to download the package which might contain sensitive information. ### Patches 1.11.7 ### Workarounds The access to the page can be manually restricted to a specific set of users or groups.
O3 Security · Impact-Aware SCA

Is CVE-2025-27604 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-27604: application-confluence — Fixed in 1.11.7