CVE-2025-27512 — zincati
Fix: coreos/zincati@01d8e89CVE-2025-27512 is a CWE-783 vulnerability in zincati. A fix is available for zincati — see the affected versions and patch details below.
Zincati allows unprivileged access to rpm-ostree D-Bus `Deploy()` and `FinalizeDeployment()` methods
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-27512.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
zincatiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Zincati ships a polkit rule which allows the zincati system user to use the following actions:
org.projectatomic.rpmostree1.deploy: used to deploy updates to the systemorg.projectatomic.rpmostree1.finalize-deployment: used to reboot the system into the deployed update
Since Zincati v0.0.24, this polkit rule contains a logic error which broadens access of those polkit actions to any unprivileged user rather than just the zincati system user.
In practice, this means that any unprivileged user with access to the system D-Bus socket is able to deploy older Fedora CoreOS versions (which may have other known vulnerabilities). Note that rpm-ostree enforces that the selected version must be from the same branch the system is currently on so this cannot directly be used to deploy an attacker-controlled update payload.
This primarily impacts users running untrusted workloads with access to the system D-Bus socket. Note that in general, untrusted workloads should not be given this access, whether containerized or not. By default, containers do not have access to the system D-Bus socket.
Patches
The logic error is fixed in Zincati v0.0.30. The fix is included in the following FCOS releases:
- On the
stablestream: 41.20250302.3.2 - On the
testingstream: 41.20250315.2.0 - On the
nextstream: 42.20250316.1.0
Workarounds
A workaround is to add the following polkit rule:
polkit.addRule(function(action, subject) {
if (action.id == "org.projectatomic.rpmostree1.deploy" ||
action.id == "org.projectatomic.rpmostree1.finalize-deployment" ||
action.id == "org.projectatomic.rpmostree1.cleanup") {
if (subject.user != "zincati") {
return polkit.Result.NO;
}
}
});
to e.g. /etc/polkit-1/rules.d/00-zincati-fix.rules (it must sort earlier than zincati.rules lexicographically).
Note that this rule will deny all non-root users other than zincati from using those actions. If you've added polkit rules to allow e.g. the core user or other users, you will need to adjust the policy (or make sure the ordering is appropriate).
References
This issue was introduced by this commit, and is fixed in v0.0.30.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | zincati | ≥ 0.0.24&&< 0.0.30 | 0.0.30cargo update -p zincati --precise 0.0.30 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zincati, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zincati to 0.0.30 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-27512 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-27512 in your dependencies?
Find it across crates.io, including transitive dependencies.