CVE-2025-27146 is a low-severity (CVSS 2.7) CWE-77 vulnerability in matrix-appservice-irc. A fix is available for matrix-appservice-irc — see the affected versions and patch details below.
Matrix IRC Bridge allows IRC command injection to own puppeted user
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-27146.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
matrix-appservice-ircnpmDescription
Impact
The matrix-appservice-irc bridge up to version 3.0.3 contains a vulnerability which can lead to arbitrary IRC command execution as the puppeted user. The attacker can only inject commands executed as their own IRC user.
Patches
The vulnerability has been patched in matrix-appservice-irc version 3.0.4.
For more information
If you have any questions or comments about this advisory, please email us at security at matrix.org.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | matrix-appservice-irc | all versions | 3.0.4npm install matrix-appservice-irc@3.0.4 |
Affected Products
matrix irc bridgematrixDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for matrix-appservice-irc, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update matrix-appservice-irc to 3.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-27146 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2025-27146 in your dependencies?
Find it across npm, including transitive dependencies.