NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CVE-2025-26528 — moodle

LOW

CVE-2025-26528 is a low-severity (CVSS 3.4) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Stored XSS in ddimageortext question type

Also known asBIT-moodle-2025-26528GHSA-h697-w4ph-7pcx
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-26528.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs22th percentile — riskier than 22% of all scored CVEsHighest risk
0.00%0.40%0.80%1.21%0.7%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The drag-and-drop onto image (ddimageortext) question type required additional sanitizing to prevent a stored XSS risk.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.5.0-beta&&< 4.5.24.5.2composer require moodle/moodle:^4.5.2
🐘Packagistmoodle/moodle≥ 4.4.0-beta&&< 4.4.64.4.6composer require moodle/moodle:^4.4.6
🐘Packagistmoodle/moodle≥ 4.3.0-beta&&< 4.3.104.3.10composer require moodle/moodle:^4.3.10
🐘Packagistmoodle/moodleall versions4.1.16composer require moodle/moodle:^4.1.16

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 4.5.0 && < 4.5.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-26528 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The drag-and-drop onto image (ddimageortext) question type required additional sanitizing to prevent a stored XSS risk.
O3 Security · Impact-Aware SCA

Is CVE-2025-26528 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-26528: moodle XSS — Fixed in 4.5.2