NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-26511 — cassandra-lucene-index-pl…

HIGHFix: instaclustr/cassandra-lucene-index@44ab4b6

CVE-2025-26511 is a high-severity (CVSS 8.8) CWE-863 vulnerability in com.instaclustr:cassandra-lucene-index-plugin. A fix is available for com.instaclustr:cassandra-lucene-index-plugin — see the affected versions and patch details below.

Cassandra-Lucene-Index allows bypass of Cassandra RBAC

Also known asGHSA-mrqp-q7vx-v2cx
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-26511.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs48th percentile — riskier than 48% of all scored CVEsHighest risk
0.00%0.36%0.72%1.08%0.0%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕com.instaclustr:cassandra-lucene-index-plugin☕com.instaclustr:cassandra-lucene-index-plugin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Summary / Details Systems running the Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 and 4.1.0-1.0.0 through 4.1.8-1.0.0, installed into Apache Cassandra version 4.x, are susceptible to a vulnerability which when successfully exploited could allow authenticated Cassandra users to remotely bypass RBAC to access data and and escalate their privileges.

Affected Versions

  • Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0
  • versions 4.1.0-1.0.0 through 4.1.8-1.0.0 when installed into Apache Cassandra version 4.x.

Required Configuration for Exploit These are the conditions required to enable exploit:

  1. Cassandra 4.x
  2. Vulnerable version of the Cassandra-Lucene-Index plugin configured for use
  3. Data added to tables
  4. Lucene index created
  5. Cassandra flush has run

Mitigation/Prevention Mitigation requires dropping all Lucene indexes and stopping use of the plugin. Exploit will be possible any time the required conditions are met.

Solution Upgrade to a fixed version of the Cassandra-Lucene-Index plugin.
Review users in Cassandra to validate all superuser privileges.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.instaclustr:cassandra-lucene-index-plugin≥ 4.0-rc1-1.0.0&&< 4.0.17-1.0.04.0.17-1.0.0com.instaclustr:cassandra-lucene-index-plugin:4.0.17-1.0.0
☕Mavencom.instaclustr:cassandra-lucene-index-plugin≥ 4.1.0-1.0.0&&< 4.1.8-1.0.14.1.8-1.0.1com.instaclustr:cassandra-lucene-index-plugin:4.1.8-1.0.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.instaclustr:cassandra-lucene-index-plugin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.instaclustr:cassandra-lucene-index-plugin to 4.0.17-1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-26511 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

**Summary / Details** Systems running the Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 and 4.1.0-1.0.0 through 4.1.8-1.0.0, installed into Apache Cassandra version 4.x, are susceptible to a vulnerability which when successfully exploited could allow authenticated Cassandra users to remotely bypass RBAC to access data and and escalate their privileges. **Affected Versions** - Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 - versions 4.1.0-1.0.0 through 4.1.8-1.0.0 when installed into Apache Cassandra versio
O3 Security · Impact-Aware SCA

Is CVE-2025-26511 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-26511: Fixed in 4.0.17-1.0.0 (High 8.8)