NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
LOW severity

CVE-2025-2570 — server

LOW

CVE-2025-2570 is a low-severity (CVSS 2.7) CWE-863 vulnerability in github.com/mattermost/mattermost/server/v8. A fix is available for github.com/mattermost/mattermost/server/v8 — see the affected versions and patch details below.

System Admin Cannot Access Environment settings in System Console While System Manager Can

Also known asGHSA-fpff-wj6m-grvrGO-2025-3694
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-2570.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs28th percentile — riskier than 28% of all scored CVEsHighest risk
0.00%0.28%0.56%0.84%0.2%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.5.x <= 10.5.3, 9.11.x <= 9.11.11 fail to check RestrictSystemAdmin setting if user doesn't have access to ExperimentalSettings which allows a System Manager to access ExperimentSettings when RestrictSystemAdmin is true via System Console.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.5.0&&< 10.5.310.5.3go get github.com/mattermost/mattermost/server/v8@v10.5.3
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.11.0&&< 9.11.129.11.12go get github.com/mattermost/mattermost/server/v8@v9.11.12
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20250411064244-844447fbd57cgo get github.com/mattermost/mattermost/server/v8@v8.0.0-20250411064244-844447fbd57c

Affected Products

1 product · 2 configurations
Application
mattermost servermattermost
≥ 10.5.0 && < 10.5.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost/server/v8, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost/server/v8 to 10.5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-2570 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Mattermost versions 10.5.x <= 10.5.3, 9.11.x <= 9.11.11 fail to check `RestrictSystemAdmin` setting if user doesn't have access to `ExperimentalSettings` which allows a System Manager to access `ExperimentSettings` when `RestrictSystemAdmin` is true via System Console.
O3 Security · Impact-Aware SCA

Is CVE-2025-2570 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-2570: server — Fixed in 10.5.3