NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2025-24409 — community-edition

HIGH

CVE-2025-24409 is a high-severity (CVSS 8.2) CWE-863 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Adobe Commerce | Incorrect Authorization (CWE-863)

Also known asGHSA-vw47-79jv-3598
Published
Updated
Affected
10 pkgs
Patched
4 / 10
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-24409.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.79%1.18%0.1%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

10 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition+2 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Incorrect Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access, leading to both a High impact to confidentiality and Low impact to integrity. Exploitation of this issue does not require user interaction.

Affected Packages

10 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.4.7-beta1&&< 2.4.7-p42.4.7-p4composer require magento/community-edition:^2.4.7-p4
🐘Packagistmagento/community-edition≥ 2.4.6-p1&&< 2.4.6-p92.4.6-p9composer require magento/community-edition:^2.4.6-p9
🐘Packagistmagento/community-edition≥ 2.4.5-p1&&< 2.4.5-p112.4.5-p11composer require magento/community-edition:^2.4.5-p11
🐘Packagistmagento/community-editionall versions2.4.4-p12composer require magento/community-edition:^2.4.4-p12
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-editionall versionsNo fix

Affected Products

3 products · 91 configurations
Application
commerceadobe
< 2.4.4
5 versions
2.4.42.4.52.4.62.4.72.4.8
Application
commerce b2badobe
< 1.3.3
5 versions
1.3.31.3.41.3.51.4.21.5.0
Application
magentoadobe
< 2.4.4
5 versions
2.4.42.4.52.4.62.4.72.4.8

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.4.7-p4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-24409 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Incorrect Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access, leading to both a High impact to confidentiality and Low impact to integrity. Exploitation of this issue does not require user interaction.
O3 Security · Impact-Aware SCA

Is CVE-2025-24409 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2025-24409: community-edition — Fixed in 2.4.7-p4