CVE-2025-24294 is a medium-severity (CVSS 5.3) Uncontrolled Resource Consumption vulnerability in resolv. A fix is available for resolv — see the affected versions and patch details below.
resolv vulnerable to DoS via insufficient DNS domain name length validation
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-24294.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
resolv💎resolv💎resolvReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
A denial of service vulnerability has been discovered in the resolv gem bundled with Ruby.
Details
The vulnerability is caused by an insufficient check on the length of a decompressed domain name within a DNS packet.
An attacker can craft a malicious DNS packet containing a highly compressed domain name. When the resolv library parses such a packet, the name decompression process consumes a large amount of CPU resources, as the library does not limit the resulting length of the name.
This resource consumption can cause the application thread to become unresponsive, resulting in a Denial of Service condition.
Affected Version
The vulnerability affects the resolv gem bundled with the following Ruby series:
- Ruby 3.2 series: resolv version 0.2.2 and earlier
- Ruby 3.3 series: resolv version 0.3.0
- Ruby 3.4 series: resolv version 0.6.1 and earlier
Credits
Thanks to Manu for discovering this issue.
History
Originally published at 2025-07-08 07:00:00 (UTC)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | resolv | all versions | 0.2.3bundle update resolv --conservative |
| 💎RubyGems | resolv | ≥ 0.4.0&&< 0.6.2 | 0.6.2bundle update resolv --conservative |
| 💎RubyGems | resolv | ≥ 0.3.0&&< 0.3.1 | 0.3.1bundle update resolv --conservative |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for resolv, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update resolv to 0.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-24294 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate impact affects Red Hat Insights compliance-backend and Red Hat Enterprise Linux Ruby packages in the affected RHEL streams. A remote attacker without privileges can send a crafted DNS packet containing a highly compressed domain name to a process using the resolv gem; excessive decompression CPU consumption…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-24294 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | ruby-0:3.3.10-11.el10_1 | RHSA-2025:23141 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | ruby-0:3.3.10-11.el10_0 | RHSA-2025:23927 |
| Red Hat Enterprise Linux 8 | ruby:3.3-8100020251124151715.489197e6 | RHSA-2025:23062 |
| Red Hat Enterprise Linux 9 | ruby:3.3-9070020251113101221.9 | RHSA-2025:23063 |
| Red Hat Enterprise Linux 9.6 Extended Update Support | ruby:3.3-9060020251210162455.9 | RHSA-2025:23648 |
Frequently Asked Questions
Is CVE-2025-24294 in your dependencies?
Find it across RubyGems, including transitive dependencies.