CVE-2025-23391 — rancher
CRITICALCVE-2025-23391 is a critical-severity (CVSS 9.1) CWE-266 vulnerability in github.com/rancher/rancher. A fix is available for github.com/rancher/rancher — see the affected versions and patch details below.
Rancher: Restricted Administrator can change Administrator's passwords
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-23391.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/rancher/rancher🐹github.com/rancher/rancher🐹github.com/rancher/rancherReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability has been identified within Rancher where a Restricted Administrator can change the password of Administrators and take over their accounts.
A Restricted Administrator should be not allowed to change the password of more privileged users unless it contains the Manage Users permissions.
Rancher deployments where the Restricted Administrator role is not being used are not affected by this CVE. Please consult the associated MITRE ATT&CK - Technique - Abuse Elevation Control Mechanism for further information about this category of attack.
Patches
The fix introduces a few changes:
- If the user has a manage-users verb, the user is allowed to edit/delete users. That way the Manage Users built in role will still be able to edit ALL users.
- If the user doesn't have manage-users, just edit or delete, then there is a check to ensure that the User being edited only has rules equal to or less than the editor.
Patched versions include releases v2.8.14, v2.9.8, v2.10.4 and v2.11.0
Workarounds
Users are recommended to upgrade, as soon as possible, to a version of Rancher Manager that contains the fix. If users can't upgrade, the following are recommended:
- Limit access to Rancher Restricted Admin only to trusted users.
- Downgrade Restricted Administrators to custom roles with limited permissions.
Credits
This issue was identified and reported by Xavier Duthil from OVHcloud.
References
If you have any questions or comments about this advisory:
- Reach out to the SUSE Rancher Security team for security related inquiries.
- Open an issue in the Rancher repository.
- Verify with our support matrix and product support lifecycle.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/rancher | ≥ 2.8.0&&< 2.8.14 | 2.8.14go get github.com/rancher/rancher@v2.8.14 |
| 🐹Go | github.com/rancher/rancher | ≥ 2.9.0&&< 2.9.8 | 2.9.8go get github.com/rancher/rancher@v2.9.8 |
| 🐹Go | github.com/rancher/rancher | ≥ 2.10.0&&< 2.10.4 | 2.10.4go get github.com/rancher/rancher@v2.10.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/rancher, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/rancher to 2.8.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-23391 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-23391 in your dependencies?
Find it across Go, including transitive dependencies.