CVE-2025-22871 is a critical-severity (CVSS 9.1) vulnerability in spiral/roadrunner. A fix is available for spiral/roadrunner — see the affected versions and patch details below.
RoadRunner is at risk of HTTP Request/Response Smuggling through vulnerable dependency
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-22871.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
spiral/roadrunnerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The net/http package dependency used by RoadRunner improperly accepts a bare LF as a line terminator in chunked data chunk-size lines. This can permit request smuggling if a net/http server is used in conjunction with a server that incorrectly accepts a bare LF as part of a chunk-ext.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | spiral/roadrunner | all versions | 2025.1.0composer require spiral/roadrunner:^2025.1.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for spiral/roadrunner, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update spiral/roadrunner to 2025.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-22871 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Satellite is rated as Low severity for this vulnerability. However, other affected components remain Moderate. Satellite uses the affected Go net/http component solely as a client to make requests, not as a server. Since this vulnerability only affects server-side usage, Satellite is not directly exposed to…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-22871 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Cryostat 4 on RHEL 9 | cryostat/cryostat-agent-init-rhel9:0.5.1-2 | RHSA-2025:10323 |
| OADP-1.4-RHEL-9 | oadp/oadp-velero-rhel9:1.4.5-20 | RHSA-2025:11396 |
| Red Hat Advanced Cluster Management for Kubernetes 2.13 for RHEL 9 | rhacm2/lighthouse-agent-rhel9:v0.20.1-1 | RHSA-2025:8691 |
| Red Hat Advanced Cluster Security 4.7 | advanced-cluster-security/rhacs-central-db-rhel8:4.7.5-4 | RHSA-2025:11479 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | receptor-0:1.5.7-1.el8ap | RHSA-2025:9975 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | automation-gateway-proxy-0:2.5.10-2.el8ap | RHSA-2025:9986 |
| Red Hat Ceph Storage 7.1 | rhceph/grafana-rhel10:11.6.2-9 | RHSA-2025:13671 |
| Red Hat Ceph Storage 8.1 | rhceph/grafana-rhel9:11.6.2-4 | RHSA-2025:11749 |
Frequently Asked Questions
Is CVE-2025-22871 in your dependencies?
Find it across Packagist, including transitive dependencies.