NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-2240 — smallrye-fault-tolerance-…

HIGHFix: smallrye/smallrye-fault-tolerance#985

CVE-2025-2240 is a high-severity (CVSS 7.5) CWE-1325 vulnerability in io.smallrye:smallrye-fault-tolerance-core. A fix is available for io.smallrye:smallrye-fault-tolerance-core — see the affected versions and patch details below.

Smallrye-fault-tolerance: smallrye fault tolerance

Also known asGHSA-gfh6-3pqw-x2j4
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-2240.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.73%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕io.smallrye:smallrye-fault-tolerance-core☕io.smallrye:smallrye-fault-tolerance-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Smallrye, where smallrye-fault-tolerance is vulnerable to an out-of-memory (OOM) issue. This vulnerability is externally triggered when calling the metrics URI. Every call creates a new object within meterMap and may lead to a denial of service (DoS) issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.smallrye:smallrye-fault-tolerance-core≥ 6.3.0&&< 6.4.26.4.2io.smallrye:smallrye-fault-tolerance-core:6.4.2
☕Mavenio.smallrye:smallrye-fault-tolerance-core≥ 6.5.0&&< 6.9.06.9.0io.smallrye:smallrye-fault-tolerance-core:6.9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.smallrye:smallrye-fault-tolerance-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.smallrye:smallrye-fault-tolerance-core to 6.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-2240 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This vulnerability allows a remote attacker to cause an out-of-memory issue when calling the metrics URI, resulting in a denial of service. As this flaw can be triggered via the network, it has been rated with an important severity.

Workaround published by Red Hat
Red Hat has investigated whether a possible mitigation exists for this issue, and has not been able to identify a practical example. Please update the affected package as soon as possible.
Source: Red Hat security advisory for CVE-2025-2240 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat build of Apache Camel 4.8.5 for Spring Bootsmallrye-fault-tolerance-coreRHSA-2025:3543
Red Hat Build of Apache Camel 4.8 for Quarkus 3.15quarkus-camel-bomRHSA-2025:3541
Red Hat build of Quarkus 3.15.4smallrye-fault-tolerance-coreRHSA-2025:3376

Frequently Asked Questions

A flaw was found in Smallrye, where smallrye-fault-tolerance is vulnerable to an out-of-memory (OOM) issue. This vulnerability is externally triggered when calling the metrics URI. Every call creates a new object within meterMap and may lead to a denial of service (DoS) issue.
O3 Security · Impact-Aware SCA

Is CVE-2025-2240 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-2240: smallrye-fault-tolerance — Fixed in 6.4.2