NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-22235 — spring-boot

HIGH

CVE-2025-22235 is a high-severity (CVSS 7.3) Improper Input Validation vulnerability in org.springframework.boot:spring-boot. A fix is available for org.springframework.boot:spring-boot — see the affected versions and patch details below.

Spring Boot EndpointRequest.to() creates wrong matcher if actuator endpoint is not exposed

Published
Updated
Affected
5 pkgs
Patched
2 / 5
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-22235.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.31%0.63%0.94%0.4%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.springframework.boot:spring-boot☕org.springframework.boot:spring-boot☕org.springframework.boot:spring-boot☕org.springframework.boot:spring-boot☕org.springframework.boot:spring-boot

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

EndpointRequest.to() creates a matcher for null/** if the actuator endpoint, for which the EndpointRequest has been created, is disabled or not exposed.

Your application may be affected by this if all the following conditions are met:

  • You use Spring Security
  • EndpointRequest.to() has been used in a Spring Security chain configuration
  • The endpoint which EndpointRequest references is disabled or not exposed via web
  • Your application handles requests to /null and this path needs protection

You are not affected if any of the following is true:

  • You don't use Spring Security
  • You don't use EndpointRequest.to()
  • The endpoint which EndpointRequest.to() refers to is enabled and is exposed
  • Your application does not handle requests to /null or this path does not need protection

Affected Packages

5 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.boot:spring-bootall versionsNo fix
☕Mavenorg.springframework.boot:spring-boot≥ 3.1.0No fix
☕Mavenorg.springframework.boot:spring-boot≥ 3.2.0No fix
☕Mavenorg.springframework.boot:spring-boot≥ 3.3.0&&< 3.3.113.3.11org.springframework.boot:spring-boot:3.3.11
☕Mavenorg.springframework.boot:spring-boot≥ 3.4.0&&< 3.4.53.4.5org.springframework.boot:spring-boot:3.4.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.boot:spring-boot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2025-22235; check the affected-versions list above or the advisory for the patched release of org.springframework.boot:spring-boot, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Your application may be affected by this if all the following conditions are met: - You use Spring Security - EndpointRequest.to() has been used in a Spring Security chain configuration - The endpoint which EndpointRequest references is disabled or not exposed via web - Your application handles requests to /null and…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2025-22235 (CC BY 4.0)

Frequently Asked Questions

EndpointRequest.to() creates a matcher for null/** if the actuator endpoint, for which the EndpointRequest has been created, is disabled or not exposed. Your application may be affected by this if all the following conditions are met: * You use Spring Security * EndpointRequest.to() has been used in a Spring Security chain configuration * The endpoint which EndpointRequest references is disabled or not exposed via web * Your application handles requests to /null and this path needs protection You are not affected if any of the following is true: * You don't use Spring Secur
O3 Security · Impact-Aware SCA

Is CVE-2025-22235 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-22235: spring-boot — Fixed in 3.3.11