NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2025-20621 — server

MEDIUM

CVE-2025-20621 is a medium-severity (CVSS 6.5) CWE-1287 vulnerability in github.com/mattermost/mattermost/server/v8. A fix is available for github.com/mattermost/mattermost/server/v8 — see the affected versions and patch details below.

Webapp crash via object that can't be cast to String in Attachment Field

Also known asGHSA-w6xh-c82w-h997GO-2025-3407
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-20621.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.33%0.65%0.98%0.4%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly handle posts with attachments containing fields that cannot be cast to a String, which allows an attacker to cause the webapp to crash via creating and sending such a post to a channel.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.2.0&&< 10.2.110.2.1go get github.com/mattermost/mattermost/server/v8@v10.2.1
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.1.0&&< 10.1.410.1.4go get github.com/mattermost/mattermost/server/v8@v10.1.4
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 10.0.0&&< 10.0.410.0.4go get github.com/mattermost/mattermost/server/v8@v10.0.4
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.11.0&&< 9.11.69.11.6go get github.com/mattermost/mattermost/server/v8@v9.11.6
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20241127161322-25ff7a3779a5go get github.com/mattermost/mattermost/server/v8@v8.0.0-20241127161322-25ff7a3779a5

Affected Products

1 product · 4 configurations
Application
mattermost servermattermost
≥ 10.1.0 && < 10.1.4
1 version
10.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost/server/v8, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost/server/v8 to 10.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-20621 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly handle posts with attachments containing fields that cannot be cast to a String, which allows an attacker to cause the webapp to crash via creating and sending such a post to a channel.
O3 Security · Impact-Aware SCA

Is CVE-2025-20621 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-20621: server — Fixed in 10.2.1