NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2025-1756 — mongosh

HIGH

CVE-2025-1756 is a high-severity (CVSS 7.5) CWE-426 vulnerability in mongosh. A fix is available for mongosh — see the affected versions and patch details below.

MongoDB Shell may be susceptible to local privilege escalation in Windows

Also known asGHSA-f5w3-73h4-jpcm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-1756.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs5th percentile — riskier than 5% of all scored CVEsHighest risk
0.00%0.22%0.44%0.66%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mongoshnpm
25Kdownloads / week

Description

mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmongoshall versions2.3.0npm install mongosh@2.3.0

Affected Products

13 products · 13 configurations
Application
mongoshmongodb
< 2.3.0
range
Application
codeready linux builder eusredhat
1 version
9.4
Application
codeready linux builder for arm64 eusredhat
1 version
9.4_aarch64
Application
codeready linux builder for ibm z systems eusredhat
1 version
9.4_s390x
Application
codeready linux builder for power little endian eusredhat
1 version
9.4_ppc64le
OS
enterprise linux eusredhat
1 version
9.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mongosh, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mongosh to 2.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-1756 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0
O3 Security · Impact-Aware SCA

Is CVE-2025-1756 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-1756: mongosh PrivEsc — Fixed in 2.3.0