CVE-2025-14986 — server
Fix: temporalio/temporal#8839CVE-2025-14986 is a CWE-863 vulnerability in go.temporal.io/server. A fix is available for go.temporal.io/server — see the affected versions and patch details below.
ExecuteMultiOperation Namespace Policy Bypass
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-14986.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
go.temporal.io/server🐹go.temporal.io/server🐹go.temporal.io/serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
When frontend.enableExecuteMultiOperation is enabled, the server can apply namespace-scoped validation and feature gates for the embedded StartWorkflowExecutionRequest using its Namespace field rather than the outer, authorized ExecuteMultiOperationRequest.Namespace. This allows a caller authorized for one namespace to bypass that namespace's limits/policies by setting the embedded start request's namespace to a different namespace. The workflow is still created in the outer (authorized) namespace; only validation/gating is performed under the wrong namespace context. This issue affects Temporal: from 1.24.0 through 1.29.1. Fixed in 1.27.4, 1.28.2, 1.29.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | go.temporal.io/server | ≥ 1.24.0&&< 1.27.4 | 1.27.4go get go.temporal.io/server@v1.27.4 |
| 🐹Go | go.temporal.io/server | ≥ 1.28.0&&< 1.28.2 | 1.28.2go get go.temporal.io/server@v1.28.2 |
| 🐹Go | go.temporal.io/server | ≥ 1.29.0&&< 1.29.2 | 1.29.2go get go.temporal.io/server@v1.29.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for go.temporal.io/server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update go.temporal.io/server to 1.27.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-14986 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-14986 in your dependencies?
Find it across Go, including transitive dependencies.