NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-13467 — keycloak-ldap-federation

MEDIUMFix: keycloak/keycloak@754c070

CVE-2025-13467 is a medium-severity (CVSS 5.5) Deserialization of Untrusted Data vulnerability in org.keycloak:keycloak-ldap-federation. A fix is available for org.keycloak:keycloak-ldap-federation — see the affected versions and patch details below.

Org.keycloak.storage.ldap: keycloak: deserialization of untrusted data in ldap user federation

Also known asGHSA-4hx9-48xh-5mxr
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-13467.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.0%0.5%May 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.keycloak:keycloak-ldap-federation☕org.keycloak:keycloak-ldap-federation

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in the Keycloak LDAP User Federation provider. This vulnerability allows an authenticated realm administrator to trigger deserialization of untrusted Java objects via a malicious LDAP server configuration.

Mitigation

Disable LDAP referrals in all LDAP user providers in all realms if projects cannot upgrade to the patched versions.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.keycloak:keycloak-ldap-federation≥ 26.3.0&&< 26.4.626.4.6org.keycloak:keycloak-ldap-federation:26.4.6
☕Mavenorg.keycloak:keycloak-ldap-federationall versions26.2.11org.keycloak:keycloak-ldap-federation:26.2.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-ldap-federation, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.keycloak:keycloak-ldap-federation to 26.4.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-13467 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2025-13467 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat build of Keycloak 26.2rhbk/keycloak-operator-bundle:26.2.11-1RHSA-2025:22088
Red Hat build of Keycloak 26.2.11keycloakRHSA-2025:22089
Red Hat build of Keycloak 26.4rhbk/keycloak-operator-bundle:26.4.6-1RHSA-2025:22090
Red Hat build of Keycloak 26.4.6keycloakRHSA-2025:22091

Frequently Asked Questions

A flaw was found in the Keycloak LDAP User Federation provider. This vulnerability allows an authenticated realm administrator to trigger deserialization of untrusted Java objects via a malicious LDAP server configuration. ### Mitigation Disable LDAP referrals in all LDAP user providers in all realms if projects cannot upgrade to the patched versions.
O3 Security · Impact-Aware SCA

Is CVE-2025-13467 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-13467: keycloak-ldap — Fixed in 26.4.6