NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2025-12150 — keycloak-services

LOWFix: keycloak/keycloak@4136a67

CVE-2025-12150 is a low-severity (CVSS 3.1) CWE-347 vulnerability in org.keycloak:keycloak-services. A fix is available for org.keycloak:keycloak-services — see the affected versions and patch details below.

Org.keycloak/keycloak-services: webauthn attestation statement verification bypass

Also known asBIT-keycloak-2025-12150GHSA-7g5x-9c4v-4w5r
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-12150.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs14th percentile — riskier than 14% of all scored CVEsHighest risk
0.00%0.24%0.49%0.73%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.keycloak:keycloak-services

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Keycloak’s WebAuthn registration component. This vulnerability allows an attacker to bypass the configured attestation policy and register untrusted or forged authenticators via submission of an attestation object with fmt: "none", even when the realm is configured to require direct attestation. This can lead to weakened authentication integrity and unauthorized authenticator registration.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.keycloak:keycloak-servicesall versions26.4.4org.keycloak:keycloak-services:26.4.4

Affected Products

2 products · 3 configurations
Application
build of keycloakredhat
< 26.4.4
range
Application
keycloakredhat
1 version
24.0.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-services, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.keycloak:keycloak-services to 26.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-12150 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

This issue was rated Low. The vulnerability requires user interaction to manipulate the WebAuthn registration process, has high attack complexity, and limited impact, affecting only policy enforcement within the Keycloak instance. Exploitation does not compromise confidentiality or availability, and the attacker…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2025-12150 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat build of Keycloak 26.2rhbk/keycloak-operator-bundle:26.2.11-1RHSA-2025:22088
Red Hat build of Keycloak 26.2.11see advisoryRHSA-2025:22089
Red Hat build of Keycloak 26.4rhbk/keycloak-operator-bundle:26.4.4-1RHSA-2025:21371
Red Hat build of Keycloak 26.4.4see advisoryRHSA-2025:21370

Frequently Asked Questions

A flaw was found in Keycloak’s WebAuthn registration component. This vulnerability allows an attacker to bypass the configured attestation policy and register untrusted or forged authenticators via submission of an attestation object with fmt: "none", even when the realm is configured to require direct attestation. This can lead to weakened authentication integrity and unauthorized authenticator registration.
O3 Security · Impact-Aware SCA

Is CVE-2025-12150 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-12150: keycloak-services — Fixed in 26.4.4