CVE-2025-12082 — civictheme
HIGHCVE-2025-12082 is a high-severity (CVSS 7.5) CWE-863 vulnerability in drupal/civictheme. A fix is available for drupal/civictheme — see the affected versions and patch details below.
CivicTheme Design System - Moderately critical - Information disclosure - SA-CONTRIB-2025-112
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-12082.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/civicthemeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Incorrect Authorization vulnerability in Drupal CivicTheme Design System allows Forceful Browsing. This issue affects CivicTheme Design System: from 0.0.0 before 1.12.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/civictheme | all versions | 1.12.0composer require drupal/civictheme:^1.12.0 |
Affected Products
civictheme design systemsalsa.digitalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/civictheme, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/civictheme to 1.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-12082 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-12082 in your dependencies?
Find it across Packagist, including transitive dependencies.