CVE-2025-11157 is a high-severity (CVSS 7.8) Deserialization of Untrusted Data vulnerability in feast. A fix is available for feast — see the affected versions and patch details below.
Arbitrary Code Execution in feast-dev/feast
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-11157.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
feastReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A high-severity remote code execution vulnerability exists in feast-dev/feast version 0.53.0, specifically in the Kubernetes materializer job located at feast/sdk/python/feast/infra/compute_engines/kubernetes/main.py. The vulnerability arises from the use of yaml.load(..., Loader=yaml.Loader) to deserialize /var/feast/feature_store.yaml and /var/feast/materialization_config.yaml. This method allows for the instantiation of arbitrary Python objects, enabling an attacker with the ability to modify these YAML files to execute OS commands on the worker pod. This vulnerability can be exploited before the configuration is validated, potentially leading to cluster takeover, data poisoning, and supply-chain sabotage.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | feast | all versions | 0.54.0pip install --upgrade 'feast==0.54.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for feast, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update feast to 0.54.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-11157 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated Important for Red Hat OpenShift AI because an attacker with low privileges and local access to the worker pod can modify specific YAML configuration files. This insecure deserialization allows for remote code execution, potentially leading to cluster takeover, data poisoning, and…
Implement strict access controls and least privilege principles for the Feast Kubernetes materializer job. Ensure that only authorized users and processes have write access to the `/var/feast/feature_store.yaml` and `/var/feast/materialization_config.yaml` files on the worker pods. This can be achieved through Kubernetes Role-Based Access Control (RBAC) policies and appropriate OpenShift security context constraints to limit file system access.Source: Red Hat security advisory for CVE-2025-11157 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift AI 2.25 | rhoai/odh-feature-server-rhel9:1776338381 | RHSA-2026:10184 |
Frequently Asked Questions
Is CVE-2025-11157 in your dependencies?
Find it across PyPI, including transitive dependencies.