CVE-2025-10044 is a medium-severity (CVSS 4.3) Cross-site Scripting (XSS) vulnerability in org.keycloak:keycloak-account-ui. A fix is available for org.keycloak:keycloak-account-ui — see the affected versions and patch details below.
Keycloak: keycloak error_description injection on error pages
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-10044.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.keycloak:keycloak-account-ui☕org.keycloak:keycloak-account-ui☕org.keycloak:keycloak-admin-ui☕org.keycloak:keycloak-admin-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Keycloak. Keycloak’s account console and other pages accept arbitrary text in the error_description query parameter. This text is directly rendered in error pages without validation or sanitization. While HTML encoding prevents XSS, an attacker can craft URLs with misleading messages (e.g., fake support phone numbers or URLs), which are displayed within the trusted Keycloak UI. This creates a phishing vector, potentially tricking users into contacting malicious actors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.keycloak:keycloak-account-ui | all versions | 26.2.9org.keycloak:keycloak-account-ui:26.2.9 |
| ☕Maven | org.keycloak:keycloak-account-ui | ≥ 26.3.0&&< 26.3.4 | 26.3.4org.keycloak:keycloak-account-ui:26.3.4 |
| ☕Maven | org.keycloak:keycloak-admin-ui | all versions | 26.2.9org.keycloak:keycloak-admin-ui:26.2.9 |
| ☕Maven | org.keycloak:keycloak-admin-ui | ≥ 26.3.0&&< 26.3.4 | 26.3.4org.keycloak:keycloak-admin-ui:26.3.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.keycloak:keycloak-account-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.keycloak:keycloak-account-ui to 26.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-10044 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-10044 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat build of Keycloak 26.0 | rhbk/keycloak-operator-bundle:26.0.17-1 | RHSA-2025:19923 |
| Red Hat build of Keycloak 26.0.17 | keycloak | RHSA-2025:19925 |
| Red Hat build of Keycloak 26.2 | rhbk/keycloak-operator-bundle:26.2.9-1 | RHSA-2025:16400 |
| Red Hat build of Keycloak 26.2.9 | keycloak | RHSA-2025:16399 |
Frequently Asked Questions
Is CVE-2025-10044 in your dependencies?
Find it across Maven, including transitive dependencies.