NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 SwiftURL
Not in CISA KEV
HIGH severity

CVE-2025-0509 — Sparkle

HIGHFix: sparkle-project/Sparkle#2550

CVE-2025-0509 is a high-severity (CVSS 7.3) CWE-552 vulnerability in github.com/sparkle-project/Sparkle. A fix is available for github.com/sparkle-project/Sparkle — see the affected versions and patch details below.

Signing Checks Bypass

Also known asBIT-java-2025-0509BIT-java-min-2025-0509BIT-jre-2025-0509GHSA-wc9m-r3v6-9p5h
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-0509.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.40%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦github.com/sparkle-project/Sparkle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects SwiftURL packages — download data is not available via public APIs for these ecosystems.

Description

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦SwiftURLgithub.com/sparkle-project/Sparkleall versions2.6.4

Affected Products

3 products · 4 configurations
OS
hci compute nodenetapp
all
Application
oncommand workflow automationnetapp
all
Application
sparklesparkle-project
< 2.6.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/sparkle-project/Sparkle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/sparkle-project/Sparkle to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-0509 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A security issue was found in Sparkle before version 2.6.4. An attacker can replace an existing signed update with another payload, bypassing Sparkle’s (Ed)DSA signing checks.
O3 Security · Impact-Aware SCA

Is CVE-2025-0509 in your dependencies?

Find it across SwiftURL, including transitive dependencies.

CVE-2025-0509: Sparkle — Fixed in 2.6.4