NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2024-9341 — common

MEDIUMFix: containers/common@e7db065

CVE-2024-9341 is a medium-severity (CVSS 5.4) CWE-59 vulnerability in github.com/containers/common. A fix is available for github.com/containers/common — see the affected versions and patch details below.

Podman: buildah: cri-o: fips crypto-policy directory mounting issue in containers/common go library

Also known asGHSA-mc76-5925-c5p6GO-2024-3171
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-9341.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.40%0.78%1.15%1.53%0.9%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/containers/common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in Go. When FIPS mode is enabled on a system, container runtimes may incorrectly handle certain file paths due to improper validation in the containers/common Go library. This flaw allows an attacker to exploit symbolic links and trick the system into mounting sensitive host directories inside a container. This issue also allows attackers to access critical host files, bypassing the intended isolation between containers and the host system.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/containers/commonall versions0.60.4go get github.com/containers/common@v0.60.4

Affected Products

3 products · 9 configurations
Application
commoncontainers
all
OS
enterprise linuxredhat
2 versions
8.09.0
Application
openshift container platformredhat
6 versions
4.124.134.144.154.164.17

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containers/common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/containers/common to 0.60.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-9341 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-9341 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 8container-tools:rhel8-8100020241023085649.afee755dRHSA-2024:8846
Red Hat Enterprise Linux 9podman-4:4.9.4-13.el9_4RHSA-2024:8039
Red Hat Enterprise Linux 9buildah-2:1.33.9-1.el9_4RHSA-2024:8112
Red Hat Enterprise Linux 9podman-4:5.2.2-9.el9_5RHSA-2024:9454
Red Hat Enterprise Linux 9buildah-2:1.37.5-1.el9_5RHSA-2024:9459
Red Hat OpenShift Container Platform 4.12cri-o-0:1.25.5-30.rhaos4.12.git53dc492.el8RHSA-2024:8694
Red Hat OpenShift Container Platform 4.13cri-o-0:1.26.5-26.rhaos4.13.giteb3d487.el8RHSA-2024:8690
Red Hat OpenShift Container Platform 4.14cri-o-0:1.27.8-10.rhaos4.14.git807f92c.el8RHSA-2024:8238

Frequently Asked Questions

A flaw was found in Go. When FIPS mode is enabled on a system, container runtimes may incorrectly handle certain file paths due to improper validation in the containers/common Go library. This flaw allows an attacker to exploit symbolic links and trick the system into mounting sensitive host directories inside a container. This issue also allows attackers to access critical host files, bypassing the intended isolation between containers and the host system.
O3 Security · Impact-Aware SCA

Is CVE-2024-9341 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-9341: common — Fixed in 0.60.4