CVE-2024-9313 is a high-severity (CVSS 8.8) vulnerability in github.com/ubuntu/authd. A fix is available for github.com/ubuntu/authd — see the affected versions and patch details below.
PAM module may allow accessing with the credentials of another user
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-9313.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/ubuntu/authd🐹github.com/ubuntu/authdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Authd PAM module up to version 0.3.4 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.
This is possible using tools such as su, sudo or ssh (and potentially others) that, so far, do not ensure that the PAM user at the end of the transaction is matching the one who initiated the transaction.
Authd 0.3.5 fixes this by not allowing changing the user unless it was never set before in the PAM stack.
su version that will include https://github.com/util-linux/util-linux/pull/3206 will not be affected
ssh version that will include https://github.com/openssh/openssh-portable/pull/521 will not be affected
sudo version that will include https://github.com/sudo-project/sudo/pull/412 will not be affected
login not affected
passwd not affected
Summary
An user can access as another user using its own credentials
Details
I feel we’ve a security issue that is due to the fact that we allow changing the user in the cases in which that’s already provided by PAM, I’ve not tested this using the entra-id broker but it’s reproducible with the example one, but unless I’m missing something it should be independent from the broker in use.
Basically, by going to the user selection page we allow to login as any user by entering the use own credentials.
See for example: https://asciinema.org/a/VIcjpDImomaGu0wxsJJxNdmlf or https://asciinema.org/a/CV3D1gaEhn2yclqSMKCnifYPo
Basically it’s possible to logging in as user1 using the credentials of user2 or user3.
The issue doesn’t affect login or passwd, but it does affect su and sshd, since in both cases they don’t check if the PAM_USER changed before the final authentication.
Now, while those tools should likely be fixed to only read the PAM_USER once pam gave them the final ok, I think authd should not allow changing the user at all when it has been provided by PAM.
</details>Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/ubuntu/authd | all versions | 0.0.0-20240930103526-63e527496b01go get github.com/ubuntu/authd@v0.0.0-20240930103526-63e527496b01 |
| 🐹Go | github.com/ubuntu/authd | ≥ 0.1.0&&< 0.3.5 | 0.3.5go get github.com/ubuntu/authd@v0.3.5 |
Affected Products
authdcanonicalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ubuntu/authd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/ubuntu/authd to 0.0.0-20240930103526-63e527496b01 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-9313 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-9313 in your dependencies?
Find it across Go, including transitive dependencies.