CVE-2024-9180 — vault
HIGHCVE-2024-9180 is a high-severity (CVSS 7.2) CWE-266 vulnerability in github.com/hashicorp/vault. A fix is available for github.com/hashicorp/vault — see the affected versions and patch details below.
Vault Operators in Root Namespace May Elevate Their Privileges
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-9180.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/vault🐹github.com/openbao/openbaoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A privileged Vault operator with write permissions to the root namespace’s identity endpoint could escalate their own or another user’s privileges to Vault’s root policy. Fixed in Vault Community Edition 1.18.0 and Vault Enterprise 1.18.0, 1.17.7, 1.16.11, and 1.15.16.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/vault | all versions | 1.18.0go get github.com/hashicorp/vault@v1.18.0 |
| 🐹Go | github.com/openbao/openbao | all versions | 2.0.3go get github.com/openbao/openbao@v2.0.3 |
Affected Products
vaulthashicorpopenbaoopenbaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/vault, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/vault to 1.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-9180 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This CVE can be mitigated by the following: * Upgrade to a version of Vault that has the fix. * Restrict write access to the root namespace’s identity endpoint. * Implement least privilege policies (e.g., via Sentinel) that limit what root-namespace operators can do. * Monitor audit logs: check for any “identity_policy” entries containing “root” to detect suspicious privilege escalations.Source: Red Hat security advisory for CVE-2024-9180 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-9180 in your dependencies?
Find it across Go, including transitive dependencies.