CVE-2024-8185 is a high-severity (CVSS 7.5) CWE-636 vulnerability in github.com/hashicorp/vault. A fix is available for github.com/hashicorp/vault — see the affected versions and patch details below.
Vault Vulnerable to Denial of Service When Processing Raft Join Requests
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-8185.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/vault🐹github.com/openbao/openbaoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Vault Community and Vault Enterprise (“Vault”) clusters using Vault’s Integrated Storage backend are vulnerable to a denial-of-service (DoS) attack through memory exhaustion through a Raft cluster join API endpoint . An attacker may send a large volume of requests to the endpoint which may cause Vault to consume excessive system memory resources, potentially leading to a crash of the underlying system and the Vault process itself.
This vulnerability, CVE-2024-8185, is fixed in Vault Community 1.18.1 and Vault Enterprise 1.18.1, 1.17.8, and 1.16.12.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/vault | ≥ 1.2.0&&< 1.18.1 | 1.18.1go get github.com/hashicorp/vault@v1.18.1 |
| 🐹Go | github.com/openbao/openbao | all versions | 2.0.3go get github.com/openbao/openbao@v2.0.3 |
Affected Products
vaulthashicorpopenbaoopenbaoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/vault, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/vault to 1.18.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-8185 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as important severity because it allows attackers to exploit the Raft cluster join API in HashiCorp Vault, leading to denial of service through memory exhaustion. The ability to send a high volume of requests can overwhelm system resources, potentially crashing both the Vault process and…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-8185 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2024-8185 in your dependencies?
Find it across Go, including transitive dependencies.