CVE-2024-6984 is a high-severity (CVSS 8.8) CWE-209 vulnerability in github.com/juju/juju. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/juju/juju — see the affected versions and patch details below.
Juju's unprivileged user running on charm node can leak any secret or relation data accessible to the local charm
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-6984.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/juju/juju🐹github.com/juju/juju🐹github.com/juju/juju🐹github.com/juju/juju🐹github.com/juju/jujuReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in Juju that resulted in the leak of the sensitive context ID, which allows a local unprivileged attacker to access other sensitive data or relation accessible to the local charm. A potential exploit where a user can run a bash loop attempting to execute hook tools. If running while another hook is executing, we log an error with the context ID, making it possible for the user to then use that ID in a following call successfully. This means an unprivileged user can access anything available via a hook tool such as config, relation data and secrets.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/juju/juju | all versions | 2.9.50go get github.com/juju/juju@v2.9.50 |
| 🐹Go | github.com/juju/juju | ≥ 3.0.0&&< 3.1.9 | 3.1.9go get github.com/juju/juju@v3.1.9 |
| 🐹Go | github.com/juju/juju | ≥ 3.2.0&&< 3.3.6 | 3.3.6go get github.com/juju/juju@v3.3.6 |
| 🐹Go | github.com/juju/juju | ≥ 3.4.0&&< 3.4.5 | 3.4.5go get github.com/juju/juju@v3.4.5 |
| 🐹Go | github.com/juju/juju | ≥ 3.5.0&&< 3.5.3 | 3.5.3go get github.com/juju/juju@v3.5.3 |
Affected Products
jujucanonicalResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/juju/juju, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/juju/juju to 2.9.50 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-6984 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-6984 in your dependencies?
Find it across Go, including transitive dependencies.