NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
HIGH severity

CVE-2024-58264 — serde-json-wasm

HIGHFix: CosmWasm/serde-json-wasm@a9a9b9b

CVE-2024-58264 is a high-severity (CVSS 7.5) CWE-674 vulnerability in serde-json-wasm. A fix is available for serde-json-wasm — see the affected versions and patch details below.

serde-json-wasm stack overflow during recursive JSON parsing

Also known asRUSTSEC-2024-0012
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-58264.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.0%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🦀serde-json-wasm🦀serde-json-wasm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

When parsing untrusted, deeply nested JSON, the stack may overflow, possibly enabling a Denial of Service attack. This was fixed by adding a check for recursion depth.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.ioserde-json-wasm≥ 1.0.0&&< 1.0.11.0.1cargo update -p serde-json-wasm --precise 1.0.1
🦀crates.ioserde-json-wasmall versions0.5.2cargo update -p serde-json-wasm --precise 0.5.2

Affected Products

1 product · 1 configurations
Application
serde-json-wasmcosmwasm
< 1.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for serde-json-wasm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update serde-json-wasm to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-58264 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Frequently Asked Questions

When parsing untrusted, deeply nested JSON, the stack may overflow, possibly enabling a Denial of Service attack. This was fixed by adding a check for recursion depth.
O3 Security · Impact-Aware SCA

Is CVE-2024-58264 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2024-58264: serde-json-wasm DoS — Fixed in 1.0.1