CVE-2024-58260 — rancher
HIGHCVE-2024-58260 is a high-severity (CVSS 7.6) CWE-863 vulnerability in github.com/rancher/rancher. A fix is available for github.com/rancher/rancher — see the affected versions and patch details below.
Rancher update on users can deny the service to the admin
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-58260.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/rancher/rancher🐹github.com/rancher/rancher🐹github.com/rancher/rancher🐹github.com/rancher/rancherReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability has been identified within Rancher Manager where a missing server-side validation on the .username field in Rancher can allow users with update permissions on other User resources to cause denial of access for targeted accounts. Specifically:
- Username takeover: A user with permission to update another user’s resource can set its
.usernameto "admin", preventing both the legitimate admin and the affected user from logging in, as Rancher enforces uniqueness at login time. - Account lockout: A user with update permissions on the admin account can change the admin’s username, effectively blocking administrative access to the Rancher UI.
This issue enables a malicious or compromised account with elevated update privileges on User resources to disrupt platform administration and user authentication.
Note: The users with these permissions to modify accounts and resources are considered as privileged users. For more information, please consult Rancher Manger’s documentation about global permissions.
Please consult the associated MITRE ATT&CK - Technique - Account Access Removal for further information about this category of attack.
Patches
This vulnerability is addressed by adding a new check in the webhook which blocks modifying usernames after it has been set. If it's empty then the username can be set to a username not already in use, but after that it is immutable.
Patched versions of Rancher include releases v2.12.2, v2.11.6, v2.10.10 and v2.9.12.
Workarounds
If you can't upgrade to a fixed version, please make sure that you are only granting update permissions on users’ related resources to trusted users.
References
If you have any questions or comments about this advisory:
- Reach out to the SUSE Rancher Security team for security related inquiries.
- Open an issue in the Rancher repository.
- Verify with our support matrix and product support lifecycle.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/rancher | ≥ 2.12.0&&< 2.12.2 | 2.12.2go get github.com/rancher/rancher@v2.12.2 |
| 🐹Go | github.com/rancher/rancher | ≥ 2.11.0&&< 2.11.6 | 2.11.6go get github.com/rancher/rancher@v2.11.6 |
| 🐹Go | github.com/rancher/rancher | ≥ 2.10.0&&< 2.10.10 | 2.10.10go get github.com/rancher/rancher@v2.10.10 |
| 🐹Go | github.com/rancher/rancher | ≥ 2.9.0&&< 2.9.12 | 2.9.12go get github.com/rancher/rancher@v2.9.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/rancher, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/rancher to 2.12.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-58260 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-58260 in your dependencies?
Find it across Go, including transitive dependencies.