CVE-2024-5798 — vault
LOWCVE-2024-5798 is a low-severity (CVSS 2.6) Improper Authentication vulnerability in github.com/hashicorp/vault. A fix is available for github.com/hashicorp/vault — see the affected versions and patch details below.
Vault Incorrectly Validated JSON Web Tokens (JWT) Audience Claims
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-5798.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/vault🐹github.com/hashicorp/vault🐹github.com/hashicorp/vaultReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Vault and Vault Enterprise did not properly validate the JSON Web Token (JWT) role-bound audience claim when using the Vault JWT auth method. This may have resulted in Vault validating a JWT the audience and role-bound claims do not match, allowing an invalid login to succeed when it should have been rejected.
This vulnerability, CVE-2024-5798, was fixed in Vault and Vault Enterprise 1.17.0, 1.16.3, and 1.15.9
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/vault | ≥ 1.17.0-rc1&&< 1.17.0 | 1.17.0go get github.com/hashicorp/vault@v1.17.0 |
| 🐹Go | github.com/hashicorp/vault | ≥ 1.16.0-rc1&&< 1.16.3 | 1.16.3go get github.com/hashicorp/vault@v1.16.3 |
| 🐹Go | github.com/hashicorp/vault | ≥ 0.11.0&&< 1.15.9 | 1.15.9go get github.com/hashicorp/vault@v1.15.9 |
Affected Products
vaulthashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/vault, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/vault to 1.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-5798 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2024-5798 in your dependencies?
Find it across Go, including transitive dependencies.