CVE-2024-56526 — oxideshop-ce
HIGHCVE-2024-56526 is a high-severity (CVSS 7.5) Information Exposure vulnerability in oxid-esales/oxideshop-ce. A fix is available for oxid-esales/oxideshop-ce — see the affected versions and patch details below.
OXID eShop May Display User Information
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-56526.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
oxid-esales/oxideshop-ce🐘oxid-esales/oxideshop-metapackage-ce🐘oxid-esales/smarty-componentReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in OXID eShop before 7. CMS pages in combination with Smarty may display user information if a CMS page contains a Smarty syntax error.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | oxid-esales/oxideshop-ce | ≥ 6.0.0&&< 6.14.4 | 6.14.4composer require oxid-esales/oxideshop-ce:^6.14.4 |
| 🐘Packagist | oxid-esales/oxideshop-metapackage-ce | ≥ 6.0.0&&< 6.5.5 | 6.5.5composer require oxid-esales/oxideshop-metapackage-ce:^6.5.5 |
| 🐘Packagist | oxid-esales/smarty-component | all versions | 1.0.1composer require oxid-esales/smarty-component:^1.0.1 |
Affected Products
eshopoxid-esalesDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oxid-esales/oxideshop-ce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update oxid-esales/oxideshop-ce to 6.14.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-56526 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is CVE-2024-56526 in your dependencies?
Find it across Packagist, including transitive dependencies.