CVE-2024-56143 is a high-severity (CVSS 8.2) CWE-639 vulnerability in @strapi/core. A fix is available for @strapi/core — see the affected versions and patch details below.
Strapi Allows Unauthorized Access to Private Fields via parms.lookup
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-56143.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@strapi/corenpmDescription
Summary
It's possible to access any private fields by filtering through the lookup parameters
Details
Using the new lookup operator provided by the document service in Strapi 5, it is not properly sanitizing this query operator for private fields.
PoC
- Create a strapi app.
- Create a content-type
- In the content-type you make a new entry
- Go back to the list view
- Add
&lookup[updatedBy][password][$startsWith]=$2to the end of your url (All passwords start with $2) see that all entries are still there - Add
&lookup[updatedBy][password][$startsWith]=$3see the entry disappear proving that the search above works
Impact
An attacker can perform filtering attacks on everything related to the object, including admin passwords and reset-tokens. This means that they can gain full access to the strapi instance.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @strapi/core | ≥ 5.0.0&&< 5.5.2 | 5.5.2npm install @strapi/core@5.5.2 |
Affected Products
strapistrapiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @strapi/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @strapi/core to 5.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-56143 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-56143 in your dependencies?
Find it across npm, including transitive dependencies.