CVE-2024-55565 is a medium-severity (CVSS 4.3) CWE-835 vulnerability in nanoid. A fix is available for nanoid — see the affected versions and patch details below.
Predictable results in nanoid generation when given non-integer values
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-55565.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
nanoidnpmDescription
When nanoid is called with a fractional value, there were a number of undesirable effects:
- in browser and non-secure, the code infinite loops on while (size--)
- in node, the value of poolOffset becomes fractional, causing calls to nanoid to return zeroes until the pool is next filled
- if the first call in node is a fractional argument, the initial buffer allocation fails with an error
Version 3.3.8 and 5.0.9 are fixed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | nanoid | ≥ 4.0.0&&< 5.0.9 | 5.0.9npm install nanoid@5.0.9 |
| 📦npm | nanoid | all versions | 3.3.8npm install nanoid@3.3.8 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nanoid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nanoid to 5.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-55565 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Moderate impact: CVE-2024-55565 affects Red Hat products and components that ship nanoid in the current affected mappings. When nanoid is called with a fractional size, browser and non-secure implementations can enter an infinite loop; in Node.js, calls can return zeroes until the pool is refilled, and an initial…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2024-55565 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.12.0-1 | RHSA-2025:1249 |
| multicluster engine for Kubernetes 2.6 for RHEL 8 | multicluster-engine/assisted-image-service-rhel8:v2.6.5-2 | RHSA-2025:0778 |
| multicluster engine for Kubernetes 2.7 for RHEL 8 | multicluster-engine/assisted-service-8-rhel8:v2.7.3-7 | RHSA-2025:0723 |
| Red Hat Advanced Cluster Management for Kubernetes 2.11 for RHEL 9 | rhacm2/acm-cluster-permission-rhel9:v2.11.5-2 | RHSA-2025:0785 |
| Red Hat Advanced Cluster Management for Kubernetes 2.12 for RHEL 9 | rhacm2/acm-cli-rhel9:v2.12.2-7 | RHSA-2025:0851 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | automation-gateway-0:2.5.20250115-1.el8ap | RHSA-2025:0340 |
| Red Hat Ceph Storage 7.1 | ceph-2:18.2.1-381.el8cp | RHSA-2026:2769 |
| Red Hat Developer Hub 1.3 on RHEL 9 | rhdh-hub-container-1.3-138 | RHBA-2025:0610 |
Frequently Asked Questions
Is CVE-2024-55565 in your dependencies?
Find it across npm, including transitive dependencies.