NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-53907 — django

HIGH

CVE-2024-53907 is a high-severity (CVSS 7.5) CWE-770 vulnerability in django. A fix is available for django — see the affected versions and patch details below.

Django denial-of-service in django.utils.html.strip_tags()

Also known asBIT-django-2024-53907GHSA-8498-2h75-472jPYSEC-2024-156
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-53907.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.54%0.99%1.44%1.90%1.0%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐍django🐍django🐍django🐍django🐍django🐍django

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Django 5.1 before 5.1.4, 5.0 before 5.0.10, and 4.2 before 4.2.17. The strip_tags() method and striptags template filter are subject to a potential denial-of-service attack via certain inputs containing large sequences of nested incomplete HTML entities.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango≥ 5.1.0&&< 5.1.45.1.4pip install --upgrade 'django==5.1.4'
🐍PyPIdjango≥ 4.2.0&&< 4.2.174.2.17pip install --upgrade 'django==4.2.17'
🐍PyPIdjango≥ 5.0.0&&< 5.0.105.0.10pip install --upgrade 'django==5.0.10'
🐍PyPIdjango≥ 5.1&&< 5.1.45.1.4pip install --upgrade 'django==5.1.4'
🐍PyPIdjango≥ 5.0&&< 5.0.105.0.10pip install --upgrade 'django==5.0.10'
🐍PyPIdjango≥ 4.2&&< 4.2.174.2.17pip install --upgrade 'django==4.2.17'

Affected Products

1 product · 3 configurations
Application
djangodjangoproject
≥ 5.1 && < 5.1.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django to 5.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-53907 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This vulnerability is rated as a Moderate severity because it exposes the strip_tags() method and striptags template filter to a potential denial-of-service attack, malicious input containing large sequences of nested incomplete HTML entities could cause excessive processing, but it does not affect data…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-53907 (CC BY 4.0)
ProductFixed inAdvisory
Discovery 1 for RHEL 9discovery/discovery-server-rhel9:1.12.0-1RHSA-2025:1249
Red Hat Ansible Automation Platform 2.4 for RHEL 8ansible-automation-platform-24/aap-cloud-billing-rhel8:0.3.0-51RHSA-2024:11144
Red Hat Ansible Automation Platform 2.5 for RHEL 8ansible-automation-platform-25/aap-cloud-billing-rhel8:0.3.0-54RHSA-2024:11146
Red Hat Ansible Automation Platform 2.5 for RHEL 8automation-controller-0:4.6.6-1.el8apRHSA-2025:0340
Red Hat Ansible Automation Platform 2.5 for RHEL 8python3.11-django-0:4.2.18-1.el8apRHSA-2025:0777

Frequently Asked Questions

An issue was discovered in Django 5.1 before 5.1.4, 5.0 before 5.0.10, and 4.2 before 4.2.17. The strip_tags() method and striptags template filter are subject to a potential denial-of-service attack via certain inputs containing large sequences of nested incomplete HTML entities.
O3 Security · Impact-Aware SCA

Is CVE-2024-53907 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-53907: django — Fixed in 5.1.4