Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🐧
🐧 Linux
CISA KEV · ACTIVELY EXPLOITED
HIGH severity

CVE-2024-53197 — Kernel

HIGH

CVE-2024-53197 is a high-severity (CVSS 7.8) Out-of-bounds Write vulnerability in Kernel. It is in CISA's Known Exploited Vulnerabilities catalog (added 2025-04-09) — treat it as actively exploited and patch now. A fix is available for Kernel — see the affected versions and patch details below.

ALSA: usb-audio: Fix potential out-of-bound accesses for Extigy and Mbox devices

Also known asA-382243530ASB-A-382243530
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2025-04-09. Federal agencies were required to remediate by 2025-04-30.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2024-53197.

EPSS Exploitation Probability

via FIRST.org ↗
4.1%probability of exploitation in next 30 days
Lower Risk+0.56%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
1.07%2.32%3.57%4.82%1.8%4.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2024-53197 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 395,249 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

1 pkg affected
🐧Kernel

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Linux packages — download data is not available via public APIs for these ecosystems.

Description

In the Linux kernel, the following vulnerability has been resolved:

ALSA: usb-audio: Fix potential out-of-bound accesses for Extigy and Mbox devices

A bogus device can provide a bNumConfigurations value that exceeds the initial value used in usb_get_configuration for allocating dev->config.

This can lead to out-of-bounds accesses later, e.g. in usb_destroy_configuration.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐧LinuxKernel≥ 2.6.12&&< 4.19.3254.19.325

Affected Products

2 products · 9 configurations
OS
debian linuxdebian
1 version
11.0
OS
linux kernellinux
≥ 6.12 && < 6.12.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Kernel, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Kernel to 4.19.325 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-53197 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This CVE marked as important vulnerability because it allows a malicious or compromised USB device to trigger out-of-bounds memory accesses in the Linux kernel’s ALSA USB audio subsystem. This occurs due to improper handling of bNumConfigurations, which can lead to memory corruption or even privilege escalation if…

Workaround published by Red Hat
To mitigate this issue, prevent module snd-usb-audio from being loaded. As the snd_usb_audio module will be auto-loaded when a usb device is hot plugged, the module can be prevented by loading with the following instructions: # echo "install snd_usb_audio /bin/true" >> /etc/modprobe.d/disable-snd-usb-audio.conf The system will need to be restarted if the modules are loaded. In most circumstances, the sound kernel modules will be unable to be unloaded while any programs are active and the device are in use. If the system requires this module to work correctly, this mitigation may not be suitable. If you need further assistance, see KCS article https://access.redhat.com/solutions/41278 or…
Source: Red Hat security advisory for CVE-2024-53197 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 6 Extended Lifecycle Support - EXTENSIONkernel-0:2.6.32-754.56.1.el6RHSA-2025:2517
Red Hat Enterprise Linux 7.7 Advanced Update Supportkernel-0:3.10.0-1062.93.1.el7RHSA-2025:2514
Red Hat Enterprise Linux 7 Extended Lifecycle Supportkernel-rt-0:3.10.0-1160.133.1.rt56.1285.el7RHSA-2025:2510
Red Hat Enterprise Linux 7 Extended Lifecycle Supportkernel-0:3.10.0-1160.133.1.el7RHSA-2025:2501
Red Hat Enterprise Linux 8kernel-rt-0:4.18.0-553.44.1.rt7.385.el8_10RHSA-2025:2474
Red Hat Enterprise Linux 8kernel-0:4.18.0-553.44.1.el8_10RHSA-2025:2473
Red Hat Enterprise Linux 8.2 Advanced Update Supportkernel-0:4.18.0-193.146.1.el8_2RHSA-2025:2646
Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Supportkernel-0:4.18.0-305.151.1.el8_4RHSA-2025:2528

Frequently Asked Questions

In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Fix potential out-of-bound accesses for Extigy and Mbox devices A bogus device can provide a bNumConfigurations value that exceeds the initial value used in usb_get_configuration for allocating dev->config. This can lead to out-of-bounds accesses later, e.g. in usb_destroy_configuration.
O3 Security · Impact-Aware SCA

Is CVE-2024-53197 in your dependencies?

Find it across Linux, including transitive dependencies.

Actively Exploited: CVE-2024-53197: Kernel (High 7.8)