CVE-2024-52804 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in tornado. A fix is available for tornado — see the affected versions and patch details below.
Tornado has HTTP cookie parsing DoS vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-52804.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tornadoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Tornado is a Python web framework and asynchronous networking library. The algorithm used for parsing HTTP cookies in Tornado versions prior to 6.4.2 sometimes has quadratic complexity, leading to excessive CPU consumption when parsing maliciously-crafted cookie headers. This parsing occurs in the event loop thread and may block the processing of other requests. Version 6.4.2 fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tornado | all versions | 6.4.2pip install --upgrade 'tornado==6.4.2' |
Affected Products
tornadotornadowebDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tornado, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tornado to 6.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52804 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-52804 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | pcs-0:0.10.18-2.el8_10.4 | RHSA-2025:2872 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support | pcs-0:0.10.8-1.el8_4.6 | RHSA-2025:2955 |
| Red Hat Enterprise Linux 8.6 Telecommunications Update Service | pcs-0:0.10.12-6.el8_6.7 | RHSA-2025:2956 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | pcs-0:0.10.15-4.el8_8.4 | RHSA-2025:3109 |
| Red Hat Enterprise Linux 9 | python-tornado-0:6.4.2-1.el9_5 | RHSA-2024:10590 |
| Red Hat Enterprise Linux 9 | pcs-0:0.11.8-1.el9_5.2 | RHSA-2025:2471 |
| Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions | pcs-0:0.11.1-10.el9_0.7 | RHSA-2025:2550 |
| Red Hat Enterprise Linux 9.2 Extended Update Support | python-tornado-0:6.4.2-1.el9_2 | RHSA-2024:10836 |
Frequently Asked Questions
Is CVE-2024-52804 in your dependencies?
Find it across PyPI, including transitive dependencies.