CVE-2024-52306 is a high-severity (CVSS 7.6) Deserialization of Untrusted Data vulnerability in backpack/filemanager. A fix is available for backpack/filemanager — see the affected versions and patch details below.
FileManager Deserialization of Untrusted Data
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-52306.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
backpack/filemanager🐘backpack/filemanagerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Deserialization of untrusted data from the mimes parameter could lead to remote code execution.
Patches
Fixed in 3.0.9
Workarounds
Not needed, a composer update will solve it in a non-breaking way.
References
Reported responsibly Vladislav Gladkiy at Positive Technologies.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | backpack/filemanager | ≥ 3.0.0&&< 3.0.9 | 3.0.9composer require backpack/filemanager:^3.0.9 |
| 🐘Packagist | backpack/filemanager | all versions | 2.0.2composer require backpack/filemanager:^2.0.2 |
Affected Products
filemanagerbackpackforlaravelDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for backpack/filemanager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update backpack/filemanager to 3.0.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52306 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2024-52306 in your dependencies?
Find it across Packagist, including transitive dependencies.