CVE-2024-52284 is a high-severity (CVSS 7.7) CWE-312 vulnerability in github.com/rancher/fleet. A fix is available for github.com/rancher/fleet — see the affected versions and patch details below.
Rancher Fleet Helm Values are stored inside BundleDeployment in plain text
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-52284.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/rancher/fleet🐹github.com/rancher/fleet🐹github.com/rancher/fleetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability has been identified when using Fleet to manage Helm charts where sensitive information is passed through BundleDeployment.Spec.Options.Helm.Values may be stored in plain text. This can result in:
- Unauthorized disclosure of sensitive data: Any user with
GETorLISTpermissions onBundleDeploymentresources could retrieve Helm values containing credentials or other secrets. - Lack of encryption at rest:
BundleDeploymentis not configured for Kubernetes encryption at rest by default, causing sensitive values to remain unencrypted within the cluster datastore.
This behavior differs from Helm v3’s default approach, where chart state — including values — is stored in Kubernetes secrets, benefiting from built-in protection mechanisms. In affected scenarios, credentials and other sensitive information are exposed both at rest and in responses to API calls.
Please consult the associated MITRE ATT&CK - Technique - Credentials from Password Stores for further information about this category of attack.
For the exposure of credentials not related to Rancher, the final impact severity for confidentiality, integrity, and availability is dependent on the permissions that the leaked credentials have on their own services. It is recommended to review the potentially exposed sensitive data in this scenario and change secrets, tokens, and passwords as necessary.
Patches
This vulnerability is addressed by adding the capability for each Bundle and BundleDeployment to have a secret to store options in.
- The git job that runs
fleet applywill now create secrets for Helm values. - Fleet controller generates
bundledeploymentsand now creates a Helm values secret per bundle deployment in the cluster namespace. - Fleet agent uses the
bundledeploymentfor options, the content resource and the secret to deploy the bundle.
Patched versions of Fleet include releases v0.14.0, v0.13.1, v0.12.6 and v0.11.10.
Workarounds
If you can't upgrade to a fixed version, please make sure to specify paths to valuesFiles as simple file names, e.g.:
Instead of:
helm:
valuesFiles:
- config-chart/values.yaml # will not be excluded → risky
Use:
helm:
valuesFiles:
- values.yaml # will be excluded
References
If you have any questions or comments about this advisory:
- Reach out to the SUSE Rancher Security team for security related inquiries.
- Open an issue in the Rancher repository.
- Verify with our support matrix and product support lifecycle.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/fleet | ≥ 0.13.0&&< 0.13.1-0.20250806151509-088bcbea7edb | 0.13.1-0.20250806151509-088bcbea7edbgo get github.com/rancher/fleet@v0.13.1-0.20250806151509-088bcbea7edb |
| 🐹Go | github.com/rancher/fleet | ≥ 0.12.0&&< 0.12.6 | 0.12.6go get github.com/rancher/fleet@v0.12.6 |
| 🐹Go | github.com/rancher/fleet | ≥ 0.11.0&&< 0.11.10 | 0.11.10go get github.com/rancher/fleet@v0.11.10 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/fleet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/fleet to 0.13.1-0.20250806151509-088bcbea7edb or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52284 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-52284 in your dependencies?
Find it across Go, including transitive dependencies.