NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2024-52007 — org.hl7.fhir.dstu3

HIGHFix: hapifhir/org.hl7.fhir.core#1717

CVE-2024-52007 is a high-severity (CVSS 8.6) XML External Entity (XXE) vulnerability in ca.uhn.hapi.fhir:org.hl7.fhir.dstu3. A fix is available for ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 — see the affected versions and patch details below.

XXE vulnerability in XSLT parsing in `org.hl7.fhir.core`

Also known asGHSA-gr3c-q7xf-47vh
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-52007.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.95%1.42%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕ca.uhn.hapi.fhir:org.hl7.fhir.dstu3☕ca.uhn.hapi.fhir:org.hl7.fhir.r4☕ca.uhn.hapi.fhir:org.hl7.fhir.r4b☕ca.uhn.hapi.fhir:org.hl7.fhir.r5☕ca.uhn.hapi.fhir:org.hl7.fhir.utilities☕ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. XSLT parsing performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( <!DOCTYPE foo [<!ENTITY example SYSTEM "/etc/passwd"> ]> could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.core is being used to within a host where external clients can submit XML. This is related to GHSA-6cr6-ph3p-f5rf, in which its fix (#1571 & #1717) was incomplete. This issue has been addressed in release version 6.4.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenca.uhn.hapi.fhir:org.hl7.fhir.dstu3all versions6.4.0ca.uhn.hapi.fhir:org.hl7.fhir.dstu3:6.4.0
☕Mavenca.uhn.hapi.fhir:org.hl7.fhir.r4all versions6.4.0ca.uhn.hapi.fhir:org.hl7.fhir.r4:6.4.0
☕Mavenca.uhn.hapi.fhir:org.hl7.fhir.r4ball versions6.4.0ca.uhn.hapi.fhir:org.hl7.fhir.r4b:6.4.0
☕Mavenca.uhn.hapi.fhir:org.hl7.fhir.r5all versions6.4.0ca.uhn.hapi.fhir:org.hl7.fhir.r5:6.4.0
☕Mavenca.uhn.hapi.fhir:org.hl7.fhir.utilitiesall versions6.4.0ca.uhn.hapi.fhir:org.hl7.fhir.utilities:6.4.0
☕Mavenca.uhn.hapi.fhir:org.hl7.fhir.dstu2016mayall versions6.4.0ca.uhn.hapi.fhir:org.hl7.fhir.dstu2016may:6.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ca.uhn.hapi.fhir:org.hl7.fhir.dstu3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ca.uhn.hapi.fhir:org.hl7.fhir.dstu3 to 6.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52007 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This vulnerability is of important severity rather than moderate due to its potential to expose sensitive host data and compromise system integrity. By exploiting the XXE vulnerability, an attacker can read arbitrary files (e.g., `/etc/passwd`), perform Denial of Service (DoS) through resource exhaustion, or even…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-52007 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat build of Apache Camel 4.4.4 for Spring Bootorg.hl7.fhir.dstu2016mayRHSA-2024:9806

Frequently Asked Questions

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. XSLT parsing performed by various components are vulnerable to XML external entity injections. A processed XML file with a malicious DTD tag ( <!DOCTYPE foo [<!ENTITY example SYSTEM "/etc/passwd"> ]> could produce XML containing data from the host system. This impacts use cases where org.hl7.fhir.core is being used to within a host where external clients can submit XML. This is related to GHSA-6cr6-ph3p-f5rf, in which its fix (#1571 & #1717) was incomplete. This issue has been addressed in
O3 Security · Impact-Aware SCA

Is CVE-2024-52007 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-52007: org.hl7.fhir.dstu3 XXE — Fixed in 6.4.0