CVE-2024-50803 — source
MEDIUMCVE-2024-50803 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in redaxo/source. A fix is available for redaxo/source — see the affected versions and patch details below.
Redaxo Core CMS Cross Site Scripting (XSS)
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-50803.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
redaxo/sourceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The mediapool feature of the Redaxo Core CMS application v 5.17.1 is vulnerable to Cross Site Scripting(XSS) which allows a remote attacker to escalate privileges
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | redaxo/source | all versions | 5.18.0composer require redaxo/source:^5.18.0 |
Affected Products
redaxoredaxoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for redaxo/source, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update redaxo/source to 5.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-50803 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-50803 in your dependencies?
Find it across Packagist, including transitive dependencies.